$re = '/(?is)^(?=.*\b(test)\b)(?=.*?\b(long)\b).*/';
$str = 'This is a very long sentence used as a test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);