re = /(?is)^(?=.*\b(test)\b)(?=.*?\b(long)\b).*/
str = 'This is a very long sentence used as a test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end