#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=var modelCode = ")(.+)(?=";)"
Local $sString = "var pageTrackName = digitalData.page.pageInfo.pageTrack;" & @CRLF & _
"if(pageTrackName == "product detail" || pageTrackName == "generic product details"){ " & @CRLF & _
" var modelCode = "GT-P5100TSABTU";" & @CRLF & _
" var displayName = "Galaxy Tab 2 (10.1, 3G)".replace(/(<([^>]+)>)/gi, "");" & @CRLF & _
" digitalData.product.model_code = modelCode;" & @CRLF & _
" digitalData.product.displayName = displayName;" & @CRLF & _
" pageName += ":" + modelCode;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")