# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=var modelCode = \")(.+)(?=\";)"
test_str = ("var pageTrackName = digitalData.page.pageInfo.pageTrack;\n"
"if(pageTrackName == \"product detail\" || pageTrackName == \"generic product details\"){ \n"
" var modelCode = \"GT-P5100TSABTU\";\n"
" var displayName = \"Galaxy Tab 2 (10.1, 3G)\".replace(/(<([^>]+)>)/gi, \"\");\n"
" digitalData.product.model_code = modelCode;\n"
" digitalData.product.displayName = displayName;\n"
" pageName += \":\" + modelCode;\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.