package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^05\d{8}$`)
var str = `0512345678
0112345678
051234567
05123456783
1230512345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}