$re = '/^05\d{8}$/m';
$str = '0512345678
0112345678
051234567
05123456783
1230512345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);