$re = '/^(\d{1,2}:\d{2}:\d{2})\.(\d{3}[-> ]+\d{1,2}:\d{2}:\d{2})\.(\d{3})/m';
$str = '0:01:00.340 --> 0:01:01.380
***subtitle text***
0:01:01.380 --> 0:01:02.390
***subtitle text***';
$subst = "\i\n$1,$2,$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;