// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{1,2}:\d{2}:\d{2})\.(\d{3}[-> ]+\d{1,2}:\d{2}:\d{2})\.(\d{3})").unwrap();
let string = "0:01:00.340 --> 0:01:01.380
***subtitle text***
0:01:01.380 --> 0:01:02.390
***subtitle text***";
let substitution = "\\i\\n$1,$2,$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}