# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*[а-я])(?=.*[А-Я])[а-яА-Я]+$//gm;t' <<< "qwerty1
QWERTY1q
qwERTy
QWERTY1
QWER TY1q
Мама
авТо
гриБ
Яблоко
яБлоко
ябЛоко
яблОко
яблоКо
яблокО
агент007
стриж
ГТО
Три богатыря"