$re = '/\/sobjects\/Case\/(?<casenum>.*?)".*?"Case_Status__c":"(?<status>.*?)".*?"Emergency_Outage_Case__c":(?<emgcase>.*?)}]}/m';
$str = '{"searchRecords":[{"attributes":{"type":"Case","url":"/services/data/v43.0/sobjects/Case/500e000000Cnat2AAB"},"Id":"500e000000Cnat2AAB","Case_Status__c":"Open","Emergency_Outage_Case__c":true}]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);