// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\/sobjects\/Case\/(?<casenum>.*?)".*?"Case_Status__c":"(?<status>.*?)".*?"Emergency_Outage_Case__c":(?<emgcase>.*?)}]}"#).unwrap();
let string = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Case\",\"url\":\"/services/data/v43.0/sobjects/Case/500e000000Cnat2AAB\"},\"Id\":\"500e000000Cnat2AAB\",\"Case_Status__c\":\"Open\",\"Emergency_Outage_Case__c\":true}]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}