package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S.{29,}?[.]`)
var str = `The boy ate the apple. The sun is shining high in the sky. The answer to life the universe and everything is forty two, said the big computer.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}