$re = '/\S.{29,}?[.]/m';
$str = 'The boy ate the apple. The sun is shining high in the sky. The answer to life the universe and everything is forty two, said the big computer.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);