$re = '/([^\s{}]+)\{([^{}]*)}(?!})/m';
$str = 'new{test}anotherone{test{nest}}new1{test1}new2{test2}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);