re = /([^\s{}]+)\{([^{}]*)}(?!})/m
str = 'new{test}anotherone{test{nest}}new1{test1}new2{test2}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end