import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "vat[\\s.]*[rn]";
final String string = "vat registration no.\n"
+ "vat number:\n"
+ "our vat number\n"
+ "vat\n"
+ "VAT amount\n"
+ "VAT rate\n"
+ "seller vat.reg.no. FI25891989\n"
+ "vat rate";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}