const regex = /vat[\s.]*[rn]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('vat[\\s.]*[rn]', 'gm')
const str = `vat registration no.
vat number:
our vat number
vat
VAT amount
VAT rate
seller vat.reg.no. FI25891989
vat rate`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}