using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=')[^']+(?='(?:[^']*'[^']*'){2}[^']*$)";
string input = @"('Jade Court','Sarah M.', 4, '08/17/2017')";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}