$re = '/(?<=\')[^\']+(?=\'(?:[^\']*\'[^\']*\'){2}[^\']*$)/';
$str = '(\'Jade Court\',\'Sarah M.\', 4, \'08/17/2017\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);