use strict;
my $str = '
<!--THE BID ASK TAG-->
<TR class="spot" bgColor=\'#f1f1f1\'>
<TD>Bid/Ask</TD> <TD
align=\'middle\' ><font
color=\'\'>15.73</font></TD>
<TD align=\'middle\' > </TD>
<TD align=\'middle\' ><font
color=\'\'>15.83</font></TD>
</TR>
<TR class="spot" bgColor=\'\'>
<TD>Low/High</TD> <TD
align=\'middle\' ><font
color=\'\'>15.51</font></TD>
<TD align=\'middle\' > </TD>
<TD align=\'middle\' ><font
color=\'\'>15.86</font></TD>
</TR>
<TR class="spot" bgColor=\'#f1f1f1\'>
<TD>Change</TD> <TD
align=\'middle\' ><font
color=\'green\'>+0.12</font></TD>
<TD align=\'middle\' > </TD>
<TD align=\'middle\' ><font
color=\'green\'>+0.74%</font></TD>
</TR>
<TR class="spot" bgColor=\'\'>
<TD>30DayChg</TD> <TD
align=\'middle\' ><font
color=\'green\'>+1.23</font></TD>
<TD align=\'middle\' > </TD>
<TD align=\'middle\' ><font
color=\'green\'>+8.49%</font></TD>
</TR>
<TR class="spot" bgColor=\'#f1f1f1\'>
<TD>1YearChg</TD> <TD
align=\'middle\' ><font
color=\'red\'>-1.21</font></TD>
<TD align=\'middle\' > </TD>
<TD align=\'middle\' ><font
color=\'red\'>-7.14%</font></TD>
</TR>
';
my $regex = qr/(?<=Bid\/Ask<\/TD>)[\s\S]*?(\d{1,4}\.\d{2})[\s\S]*?(\d{1,4}\.\d{2})[\s\S]*?(?=Low\/High<\/TD>)[\s\S]*?(\d{1,4}\.\d{2})[\s\S]*?(\d{1,4}\.\d{2})[\s\S]*?(?=Change<\/TD>)[\s\S]*?((?:\+|-)\d{1,4}\.\d{2})[\s\S]*?((?:\+|-)\d{1,4}\.\d{2}%)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}