#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(H149xcV_[a-zA-Z0-9]+_[a-zA-Z0-9]+_[a-zA-Z0-9]+)"
Local $sString = ">H149xcV_Fge342_r3_h2_d1" & @CRLF & _
">H149xcV_bTr423_r3_h2_d1" & @CRLF & _
">H149xcV_kN893_r3_h2_d1" & @CRLF & _
">H149xcV_DNp021_r3_h2_d1" & @CRLF & _
">H149xcV_JEP3324_r3_h2_d1" & @CRLF & _
">H149xcV_SRt424234_r3_h2_d1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")