import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(H149xcV_[a-zA-Z0-9]+_[a-zA-Z0-9]+_[a-zA-Z0-9]+)";
final String string = ">H149xcV_Fge342_r3_h2_d1\n"
+ ">H149xcV_bTr423_r3_h2_d1\n"
+ ">H149xcV_kN893_r3_h2_d1\n"
+ ">H149xcV_DNp021_r3_h2_d1\n"
+ ">H149xcV_JEP3324_r3_h2_d1\n"
+ ">H149xcV_SRt424234_r3_h2_d1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}