import re
regex = re.compile(r"(c[0-3])(.*?)(?=c[0-3]|$)", flags=re.MULTILINE)
test_str = "c31e2f34ac2b52c1234a2d34c0324c2543fc0aa32c3885928c31f92a83"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")