re = /(c[0-3])(.*?)(?=c[0-3]|$)/m
str = 'c31e2f34ac2b52c1234a2d34c0324c2543fc0aa32c3885928c31f92a83'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end