import re
regex = re.compile(r"^(?<x_forwarded_for>(?:[0-9:.-]*, )?(?<clientip>[0-9:.-]*)) (?<ident>[^ ]*) (?<auth>[^ ]*) \[(?<time>[^\]]*)\] \"(?<verb>\S+)(?: +(?<request>[^\"]*?)(?: +(?<httpversion>\S*))?)?\" (?<response>[^ ]*) (?<bytes>[^ ]*) \"(?<referer>[^\"]*)\" \"(?<agent>[^\"]*)\" \"(?<request_time>[^\"]*)\" \"(?<host>[^\"]*)(?::(?<host_port>\S+))?\"(?: ATI:\"(?<amazn_trace_id>[^\"]*)\")?(?: \"(?<hdr_location>[^\"]*)\" \"(?<request_length>[^\"]*)\")?(?: \"(?<tls_version>[^\/]*)\/(?<tls_cipher>[^\"]*)\")?(?: trace_id:\"(?<a0_request_id>[^\"]*)\")?$")
test_str = "- - - [15/Jan/2020:15:05:36 +0000] \"GET / HTTP/1.1\" 200 14 \"-\" \"curl/7.54.0\" \"0.000\" \"localhost:8888\" ATI:\"-\" \"-\" \"78\" \"-/-\" trace_id:\"6-1579100736.791-172.17.0.1-78\""
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")