#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!(red|blue|green)\1+$)(?:red|blue|green){2,}$"
Local $sString = "Redred" & @CRLF & _
"redblue" & @CRLF & _
"redgreen" & @CRLF & _
"blue" & @CRLF & _
"redredgreen" & @CRLF & _
"blue" & @CRLF & _
"123redblue"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")