$re = '/^(?!(red|blue|green)\1+$)(?:red|blue|green){2,}$/mi';
$str = 'Redred
redblue
redgreen
blue
redredgreen
blue
123redblue';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);