import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!Apple: |Content: )(?!0{2}|666|150)\\d{3}-\\d{2}-(?!0{4})\\d{4}\\b";
final String string = "Apple: 173-12-9878 or Content: 173-12-9878\n"
+ "173-12-9878 or 173-12-9878";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}