$re = '/\b(?<!Apple: |Content: )(?!0{2}|666|150)\d{3}-\d{2}-(?!0{4})\d{4}\b/m';
$str = 'Apple: 173-12-9878 or Content: 173-12-9878
173-12-9878 or 173-12-9878';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);