#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<name>(?:[a-z0-9]+(?:[-_][a-z0-9]+)*(?<separator>[_\.#\/\\*\- ]?))?)(?<!\d)(?<number>\d+)\.(?<extension>[a-z]{3})$"
Local $sString = "tot0_tutu_00001.tif" & @CRLF & _
"tot0.0001.tif" & @CRLF & _
"tot0#00001.tif" & @CRLF & _
"tot0/0001.tif" & @CRLF & _
"tot0\00001.tif" & @CRLF & _
"tot0*0001.tif" & @CRLF & _
"00001.tif" & @CRLF & _
"tot0-tutu_0001.tif" & @CRLF & _
"tot0-tutu-00001.tif" & @CRLF & _
"tot0-tutu 000001.tif" & @CRLF & _
"tot0-tutu000001.tif"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")