import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<name>(?:[a-z0-9]+(?:[-_][a-z0-9]+)*(?<separator>[_\\.#\\/\\\\*\\- ]?))?)(?<!\\d)(?<number>\\d+)\\.(?<extension>[a-z]{3})$";
final String string = "tot0_tutu_00001.tif\n"
+ "tot0.0001.tif\n"
+ "tot0#00001.tif\n"
+ "tot0/0001.tif\n"
+ "tot0\\00001.tif\n"
+ "tot0*0001.tif\n"
+ "00001.tif\n"
+ "tot0-tutu_0001.tif\n"
+ "tot0-tutu-00001.tif\n"
+ "tot0-tutu 000001.tif\n"
+ "tot0-tutu000001.tif";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}