using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+\s\([+-]\d{1,2}(?:\.\d+)?%\)$";
string input = @"7463 (+6.16%)
11 (-5%)
255 (+42.5%)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}