$re = '/^\d+\s\([+-]\d{1,2}(?:\.\d+)?%\)$/m';
$str = '7463 (+6.16%)
11 (-5%)
255 (+42.5%)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);