import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\x19A(\\d*)d\\[?(\\d*)?\\]?(.*)-(\\S+)\\s(\\d+)\\x0C?(.*)?\\x18|\\x19A(\\d*)d(\\S*)\\s?(\\d*)\\:?(.*)\\x18|RECV,4,(\\d*),\\[?(\\d*)?\\]?(.*)-(\\S+)\\s(\\d+)\\%?0?C?(.*)?|RECV,4,(\\d*),(\\S*)\\s?(\\d*)\\:?(.*)\\s";
final String string = "A0707288dMessage\n\n"
+ "A0707288dMessage 1\n\n"
+ "A0707288dMessage 1:Cancel 1\n\n"
+ "A0707288dMessage-Location. 3\n"
+ "A0707288dMessage-Location. 3:Cancel 3\n"
+ "A0707288dMessage-Location. 3V1\n"
+ "A0707288dMessage-Location. 3:Cancel 3V1\n"
+ "A0707288d[00]Message-Location. 3\n"
+ "A0707288d[00]Message-Location. 3:Cancel 3\n"
+ "A0707288d[00]Message-Location. 3V1\n"
+ "A0707288d[00]Message-Location. 3:Cancel 3V1\n\n"
+ "RECV,4,0707288,Message\n"
+ "RECV,4,0707288,Message 1\n"
+ "RECV,4,0707288,Message 1:Cancel 1\n\n"
+ "RECV,4,0707288,Message-Location. 3\n"
+ "RECV,4,0707288,Message-Location. 3:Cancel 3\n"
+ "RECV,4,0707288,Message-Location. 3%0CV1\n"
+ "RECV,4,0707288,Message-Location. 3:Cancel 3%0CV1\n"
+ "RECV,4,0707288,[00]Message-Location. 3\n"
+ "RECV,4,0707288,[00]Message-Location. 3:Cancel 3\n"
+ "RECV,4,0707288,[00]Message-Location. 3%0CV1\n"
+ "RECV,4,0707288,[00]Message-Location. 3:Cancel 3%0CV1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}