re = /\x19A(\d*)d\[?(\d*)?\]?(.*)-(\S+)\s(\d+)\x0C?(.*)?\x18|\x19A(\d*)d(\S*)\s?(\d*)\:?(.*)\x18|RECV,4,(\d*),\[?(\d*)?\]?(.*)-(\S+)\s(\d+)\%?0?C?(.*)?|RECV,4,(\d*),(\S*)\s?(\d*)\:?(.*)\s/m
str = 'A0707288dMessage
A0707288dMessage 1
A0707288dMessage 1:Cancel 1
A0707288dMessage-Location. 3
A0707288dMessage-Location. 3:Cancel 3
A0707288dMessage-Location. 3V1
A0707288dMessage-Location. 3:Cancel 3V1
A0707288d[00]Message-Location. 3
A0707288d[00]Message-Location. 3:Cancel 3
A0707288d[00]Message-Location. 3V1
A0707288d[00]Message-Location. 3:Cancel 3V1
RECV,4,0707288,Message
RECV,4,0707288,Message 1
RECV,4,0707288,Message 1:Cancel 1
RECV,4,0707288,Message-Location. 3
RECV,4,0707288,Message-Location. 3:Cancel 3
RECV,4,0707288,Message-Location. 3%0CV1
RECV,4,0707288,Message-Location. 3:Cancel 3%0CV1
RECV,4,0707288,[00]Message-Location. 3
RECV,4,0707288,[00]Message-Location. 3:Cancel 3
RECV,4,0707288,[00]Message-Location. 3%0CV1
RECV,4,0707288,[00]Message-Location. 3:Cancel 3%0CV1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end