const regex = /^\w+(?:[ `'?!]\w+)*[`.?!]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+(?:[ `\'?!]\\w+)*[`.?!]?$', 'gm')
const str = `"Don't use" -> valid sequence
"Don''t use" -> invalid sequence
"Don'?!%^t use" -> invalid sequence
"Be quiet!" -> valid sequence
"Be quiet!><" -> invalid sequence
"123 Your name?" -> valid sequence
"123 Your name?;'" -> invalid sequence
Don't use
Don''t use
Don'?!%^t use
Be quiet!
Be quiet!><
123 Your name?
123 Your name?;'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}