$re = '/^\w+(?:[ `\'?!]\w+)*[`.?!]?$/m';
$str = '"Don\'t use" -> valid sequence
"Don\'\'t use" -> invalid sequence
"Don\'?!%^t use" -> invalid sequence
"Be quiet!" -> valid sequence
"Be quiet!><" -> invalid sequence
"123 Your name?" -> valid sequence
"123 Your name?;\'" -> invalid sequence
Don\'t use
Don\'\'t use
Don\'?!%^t use
Be quiet!
Be quiet!><
123 Your name?
123 Your name?;\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);