re = /(?:\B#)?\w+(?:-\w+)*/m
str = 'Test a#words 100-200-300
Test #words 100-200-300
Test ##words 100-200-300'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end