$re = '/(?=.*walk)(?=.*rock).+/i';
$str = 'Walk dance and rock walk
dance
walk
rock and walk
sidewalk and rockwall
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);