re = /(?=.*walk)(?=.*rock).+/i
str = 'Walk dance and rock walk
dance
walk
rock and walk
sidewalk and rockwall
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end