#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)yt(?<ytVer>[a-z])(?<ytID>[a-zA-Z0-9-_]{8,11})"
Local $sString = "https://www.youtube.com/watch?v=f7dWJcJgEjE?list" & @CRLF & _
"https://youtu.be/voceyAq-R9E" & @CRLF & _
"https://www.youtube.com/embed/f7dWJcJgEjE" & @CRLF & _
"https://youtu.be/watch?v=DKbQFMOEFTs" & @CRLF & _
"" & @CRLF & _
"ytaDKbQFMOEFTs" & @CRLF & _
"ytzvoceyAq-R9E" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")