import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\ |\\:]([\\#][0-9A-Fa-f]{6}|[\\#][0-9A-Fa-f]{3})";
final String string = "#BED\n"
+ "{\n"
+ " color: #FfFdF8; background-color:#aef;\n"
+ " font-size: 123px;\n"
+ " background: -webkit-linear-gradient(top, #f9f9f9, #fff);\n"
+ "}\n"
+ "#Cab\n"
+ "{\n"
+ " background-color: #ABC;\n"
+ " border: 2px dashed #fff;\n"
+ "} ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}