import re
regex = re.compile(r"[\ |\:]([\#][0-9A-Fa-f]{6}|[\#][0-9A-Fa-f]{3})", flags=re.MULTILINE)
test_str = ("#BED\n"
"{\n"
" color: #FfFdF8; background-color:#aef;\n"
" font-size: 123px;\n"
" background: -webkit-linear-gradient(top, #f9f9f9, #fff);\n"
"}\n"
"#Cab\n"
"{\n"
" background-color: #ABC;\n"
" border: 2px dashed #fff;\n"
"} ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")