const regex = /(?<=\d|^)\w\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d|^)\\w\\d', 'gm')
const str = `f9
f9x0
af9
3f9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}