$re = '/(?<=\d|^)\w\d/m';
$str = 'f9
f9x0
af9
3f9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);