$re = '/\'output\'\s*=>\s*array\(\n\s*(.|\n)+?\)/';
$str = '\'output\' => array(
\'selector\' => \'.tg-container\',
\'property\' => \'width\',
),';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);