$re = '/^\.*|\.*$/m';
$str = '.www.cat.com.
.www.cat.com
www.cat.com
www.cat.com.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;