re = /^\.*|\.*$/m
str = '.www.cat.com.
.www.cat.com
www.cat.com
www.cat.com.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result