#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<p><strong>PRESIDENTE ANDRÉS MANUEL LÓPEZ OBRADOR:<\/strong>\r?\n((?:(?!<p><strong>)^[^\r\n]+\r?\n)+)"
Local $sString = "<p><strong>ROGELIO JIMÉNEZ PONS:</strong> Quisiera" & @CRLF & _
"<p>Text here...</p>" & @CRLF & _
"<p><strong>PRESIDENTE ANDRÉS MANUEL LÓPEZ OBRADOR:</strong>" & @CRLF & _
"<p>Text here...</p>" & @CRLF & _
"<p>Text here...</p>" & @CRLF & _
"<p><strong>PREGUNTA:</strong>" & @CRLF & _
"<p>Text here...</p>" & @CRLF & _
"<p><strong>PRESIDENTE ANDRÉS MANUEL LÓPEZ OBRADOR:</strong>" & @CRLF & _
"<p>Y la información específica la vamos a difundir a través de una página en internet, que es: www.participacionsocial.gob.mx, en su momento vamos a establecer ahí la metodología que se va a utilizar para determinar la ubicación de los módulos," & @CRLF & _
" el número de boletas, la forma de identificación de las personas participantes y esa metodología va a explicar los criterios como la población, el padrón, la accesibilidad y la viabilidad de todo esto.</p>" & @CRLF & _
" <p>También vamos a poner toda la información del proyecto para que cualquier persona pueda consultarla y de esta manera ir fortaleciendo también toda la cuestión de la transparencia y rendición de cuentas que hemos llevado a cabo en todos los" & @CRLF & _
" procesos de consulta y ejercicios participativos durante este año de gobierno.</p>" & @CRLF & _
" <p>Gracias.</p>" & @CRLF & _
" <p>Ahora, vamos a escuchar a Adelfo Regino con el tema de las consultas indígenas.</p>" & @CRLF & _
"<p><strong>INTERLOCUTOR:</strong>" & @CRLF & _
"<p>Text here...</p>" & @CRLF & _
"<p>Text here...</p>" & @CRLF & _
"<p><strong>PRESIDENTE ANDRÉS MANUEL LÓPEZ OBRADOR:</strong>" & @CRLF & _
"<p>Text here...</p>" & @CRLF & _
"<p>Text here...</p>" & @CRLF & _
"<p>Text here...</p>" & @CRLF & _
"<p>Text here...</p>" & @CRLF & _
"<p>Text here...</p>" & @CRLF & _
"<p><strong>INTERLOCUTOR:</strong>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")