import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p><strong>PRESIDENTE ANDRÉS MANUEL LÓPEZ OBRADOR:<\\/strong>\\r?\\n((?:(?!<p><strong>)^[^\\r\\n]+\\r?\\n)+)";
final String string = "<p><strong>ROGELIO JIMÉNEZ PONS:</strong> Quisiera\n"
+ "<p>Text here...</p>\n"
+ "<p><strong>PRESIDENTE ANDRÉS MANUEL LÓPEZ OBRADOR:</strong>\n"
+ "<p>Text here...</p>\n"
+ "<p>Text here...</p>\n"
+ "<p><strong>PREGUNTA:</strong>\n"
+ "<p>Text here...</p>\n"
+ "<p><strong>PRESIDENTE ANDRÉS MANUEL LÓPEZ OBRADOR:</strong>\n"
+ "<p>Y la información específica la vamos a difundir a través de una página en internet, que es: www.participacionsocial.gob.mx, en su momento vamos a establecer ahí la metodología que se va a utilizar para determinar la ubicación de los módulos,\n"
+ " el número de boletas, la forma de identificación de las personas participantes y esa metodología va a explicar los criterios como la población, el padrón, la accesibilidad y la viabilidad de todo esto.</p>\n"
+ " <p>También vamos a poner toda la información del proyecto para que cualquier persona pueda consultarla y de esta manera ir fortaleciendo también toda la cuestión de la transparencia y rendición de cuentas que hemos llevado a cabo en todos los\n"
+ " procesos de consulta y ejercicios participativos durante este año de gobierno.</p>\n"
+ " <p>Gracias.</p>\n"
+ " <p>Ahora, vamos a escuchar a Adelfo Regino con el tema de las consultas indígenas.</p>\n"
+ "<p><strong>INTERLOCUTOR:</strong>\n"
+ "<p>Text here...</p>\n"
+ "<p>Text here...</p>\n"
+ "<p><strong>PRESIDENTE ANDRÉS MANUEL LÓPEZ OBRADOR:</strong>\n"
+ "<p>Text here...</p>\n"
+ "<p>Text here...</p>\n"
+ "<p>Text here...</p>\n"
+ "<p>Text here...</p>\n"
+ "<p>Text here...</p>\n"
+ "<p><strong>INTERLOCUTOR:</strong>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}